一、软件介绍

快比（英文名：QuickCmp,即“Quick Compare”的缩写）是由李辉开发的一款Excel/DBF文件对比和引用工具，纯绿色软件，不需安装或注册，不弹任何广告，无病毒、无任何捆绑，不写注册表，不联网，无过期时间，不限制使用的电脑数量和次数，不需用户了解掌握Excel中的函数，使用极其简单。计算机上无需安装Office、WPS或Foxpro等软件，无视原Excel工作薄里的单元格格式（这点在使用Excel时最容易出问题），对原有文件无任何影响（仅读取进本软件后进行操作，不对原文件进行任何写入或修改操作）。

兼容Windows XP/Windows Server 2003-2025/Win7/Win8/Win10/Win11系统。

（没错，在Windows XP上也可以使用！）

拖入两个文件，开始对比！

官方网站：http://www.QuickCmp.com

官方邮箱：QuickCmp@163.com

Copyright ©2025 www.QuickCmp.Com 作者：李辉 版权所有.


1.1 功能简介

本软件主要具有以下功能：

1、按一个或多个字段对比两个Excel/DBF文件中的数据（可对比相同或不同的数据）。对比结果可以按指定的对比字段排序；

2、引用其它Excel/DBF文件中的数据；

3、对Excel/DBF文件中的数据进行定义排序，可对一列或多列混合升、降序；

4、按一个或多个字段显示Excel/DBF文件中的重复数据；

5、Excel和DBF文件互相转换；

6、其它一些方便使用的功能。

直接将Excel/DBF文件拖入左侧和右侧，然后选择要对比的字段，单击“开始对比”按钮即可。


1.2 软件界面

Copyright ©2025 www.QuickCmp.Com 作者：李辉 版权所有.


二、使用本软件

Copyright ©2025 www.QuickCmp.Com 作者：李辉 版权所有.


2.1 对比两个Excel/DBF文件

要对比的两个Excel文件一般应是规范的二维表（即第1行是标题，之后的行是数据。文件中如果有合并的单元格，软件将在运行时拆分合并单元格，拆分后仅合并前的第一个单元格有数据，其它合并单元格为空）。

操作步骤：

1、选择要对比的两个Excel/DBF文件

把要对比的两个文件分别拖入软件左侧和右侧的空白区域，如下图：

软件界面的中间部分会自动列出左右两个文件中的列名（DBF文件是字段名）。若左右两侧的文件表相同的列中，则软件自动将相同的列名加入对比字段，如下图：

上述示例中，左侧Excel的有以下列：学号、姓名、性别、现民族、政治面貌，右侧Excel的有以下列：学号、姓名、性别、民族、政治面貌、出生日期、籍贯，因此软件自动将两侧文件中都有的学号、姓名、性别、政治面貌匹配上，并默认勾选按这些相同字段进行对比。

如果两侧的Excel中有不同的列名，但又想按不同的列名进行对比，可用鼠标按住左侧列名，拖放到要对比的右侧列名上即可。例如，上述示例中，左侧有个“现民族”列，右侧有个“民族”列，想把这两列加入对比条件时，把“现民族”列拖放到“民族”列上即可，如下图：

软件会自动将这两列作为对比条件且默认勾选，如下图：

如果先错了左侧列名（或不想要这个对比条件了），从对比条件区域按住鼠标，拖回“左侧列名”栏的任意，即可取消匹配，如下图：

2、选择要按哪些列名（即字段）作为对比条件

勾选要对比的字段名，软件将按您选择的字段名作为对比条件，如下图：

上述示例中，两侧文件将按用户选择的“学号”和“民族”这两列进行对比。

3、选择对比方式

选择顶端栏中的对比方式（不同数据、相同数据）。默认对比两侧文件中的不同数据。

l 不同数据：显示两侧文件中同时满足对比条件的不同数据。

l 相同数据：显示两侧文件中同时满足对比条件的相同数据。

4、开始对比

单击“开始对比”按钮，即可显示对比结果（数据量大的话对比时间可能较慢）。对比结果如下（以对比不同数据为例）：

上述示例中，按照对比条件（两侧文件中的“学号”和“民族”列的数据同时相同），左侧文件中有2条数据不在右侧文件中；右侧文件中有5条数据不在左侧文件中（见两侧下方的状态栏）。红色表示参与对比的列（仅表示参与对比的列名，不是说红色的所有单元格就是不同。对比方式为“相同数据”时不再显示红色）。

对比完成后，“开始对比”按钮变为“显示全部”。您可单击“显示全部”按钮显示对比之前的数据，然后重新选择新的对比条件，进行新一轮对比。

注意：

1、如果拖入的Excel工作薄里有多个工作表（Sheet），则：

l 如果仅一个Sheet中有数据，则直接导入；

l 如果多个Sheet中都有数据，则软件会弹出选择Sheet的对话框，要求用户选择要对比或引用哪个工作表，如下图：

2、如果Excel中第1行某些列名为空，则导入后软件会自动将其命名为Col1、Col2……

3、如果导入的Excel/DBF文件中有整行重复的数据，导入时会提示有多少条重复数据（仅提示，不做去重或其它任何操作），如下图：

4、两侧文件中，各自的数据顺序（即第几行或第几列中的数据）无所谓。


2.2 对比结果排序

对比之前，如果勾选了“对比结果按对比条件字段排序”复选框（如下图）：

则对比结果将按对比条件中勾选的字段的从上到下的顺序排序（升序）。如上图示例中，对比结果将按学号、姓名、性别、政治面貌依次升序排序。

您可以改变排序的字段次序（仅当勾选了“对比结果按对比条件字段排序”复选框时才可改变）。用鼠标按住对比条件中的字段上下拖动，对比后的结果即可按从上到下的次序排序（当然，仅按勾选的字段排序。未勾选的不参与排序）。例如，按住“姓名”这一行向下拖动到“性别”之后，同时取消勾选“学号”（如下图）：

则对比结果将按性别、姓名、政治面貌依次升序排序，如下图：


2.3 导出表格中的数据（原数据或对比结果）

在左侧或右侧表格上（或空白区域）单击鼠标右键，会弹出如下菜单：

您可以选择将当前表格中的数据导出为Excel工作薄、纯文本文件或DBF文件。

注：导出的Excel单元格全部为文本格式。若导出为DBF文件，则导出的DBF文件中的所有字段均为字符类型，长度为255。

您也可以选择将当前表格中的全部单元格（带标题或不带标题）、复制当前鼠标选中范围内的单元格（带标题或不带标题）复制到粘贴板，以便粘贴到其它文件中。


2.4 引用其它Excel/DBF文件中的数据

把希望从中引用数据的文件拖到右侧表格，软件中间下方会自动列出右侧文件中的所有列，如下图：

选择好对比条件后，勾选要引用的列名，即可把右侧表格中满足对比条件的数据引用到左侧表格中，如下图：

上述示例中，当左右两侧数据的“学号”、“姓名”和“民族”都相同时（因为勾选了这3个字段作为对比条件），将右侧文件中的“籍贯”引用到左侧文件中。左侧引用过来的“籍贯”列中为空的，表示这些为空的行不满足对比条件（即“学号”、“姓名”和“民族”这3列同时相等的情况下，在对侧找不到相同的数据）。

注意：

如果在勾选的对比条件下，右侧表格中会出现重复数据（也就是说，如果右侧表格按选择的对比字段去重时会去除重复项；或者说，右侧表格中如果仅包含选择的对比字段的列的话，会有重复的数据），则软件会弹出对下提醒对话框，提示您一定注意（否则引用后左侧表格中数据与最初导入的数据会不一致）：

软件仅提醒您，不做其它操作。您可改变对比条件来将右侧唯一的数据引用到左侧。


2.5 查看Excel/DBF文件中的重复数据数据

重复数据分为两种：

l 拖入的Excel/DBF中有重复的整行数据：软件在拖入文件时会提示（参见“2.1 对比两个Excel/DBF文件”一节中“注意”里的第3条）。

l 拖入的Excel/DBF中，部分列有重复的数据。

勾选“显示左侧重复的数据”或“显示左侧重复的数据”（如下图）：

选择要按哪些字段查看重复数据（例如，要查看“学号”和“姓名”都重复的数据），如下图：

单击“确定”按钮后，软件将按您要检查重复的字段显示出当前表格中所有重复的数据，如下图：

本软件暂不提供去重复项的功能（若需去除重复项，可使用Excel里的“去除重复项功能”。Excel里按多个字段去除重复项时，仅会保留第1条重复的数据，无法保留指定的第几条这几个字段重复的数据）。


2.6 自定义排序

自定义排序用于对开始对比前的数据（即拖入的Excel/DBF文件中的数据）进行排序。对比之后的数据（对比结果）顺序请参照“2.2 对比结果排序”中的操作。Excel自带的排序功能很容易误操作（最容易误操作的是，本应选择Sheet中的全部数据再排序，但只选了要排序的列。这样排序后，未选择的列的每行数据仍在原来的位置，导致每行数据都乱了。作者曾见过有人因这个操作差点导致严重事故），本软件中的自定义排序无视原Excel中的单元格格式，全部单元格都按文本格式排序，确保排序后每一行数据不会错乱（不会和其它行的数据混在一起）。


2.6.1 操作步骤

在左侧或右侧拖入Excel/DBF文件后，在表格上单击鼠标右键，选择“自定义排序…”，会弹出自定义排序界面，如下图：

勾选要排序的字段，然后单击此字段后“升降序”一列后的“升序”或“降序”，会显示下拉框，选择此字段的排序顺序，如下图：

您可以上下拖动字段，来改变依次排序的字段顺序，如下图：

上述示例中，按住“姓名”然后拖动到“民族”下面，然后设置“姓名”降序，如下图：

则单击“确定”按钮后，软件将表格中的数据先按“民族”升序、再按“姓名”降序进行排序，并在下方状态栏中显示当前排序字段及次序，如下图：

状态栏中的“↑”表示按此字段升序，“↓”表示按此字段降序。

若要取消自定义排序，在表格中再单击右键，选择“自定义排序…”，在自定义排序界面中，取消勾选所有字段，单击“确定”按钮即可。


2.6.2 对数字排序时的特别注意事项

因本软件将全部单元格都作为文本格式进行排序（即按字符串排序的方式，先比较第1个字符，再比较第2个字符……），因此，如果Excel中的混合有文本和常规（或数值等）格式的单元格，则本软件的排序结果可能并不是您希望的排序结果。例如以下Excel中的“序号”列混合了文本和常规格式的单元格：

则本软件中按“序号”升序排序的结果如下（即其中的2、3、9等排在了“10”的后面，因为“10”的第1个字符为“1”，故排在“2”的前面）：

这一点一定要注意。如果要对数值进行排序，不建议使用本软件的自定义排序功能（除非您确认排序结果正确）。记住，本软件中的自定义排序是把表格中的所有内容都看作字符串，按字符串比较的方式来排序的（不是按数值大小排序）。


2.7 Excel/DBF文件互相转换

本软件可直接查看DBF文件中的内容，电脑上不需要安装DBF文件查看或编辑软件。

l Excel转为DBF文件：拖入Excel文件，然后单击右键菜单，选择“另存为DBF文件…”，可以将Excel转为DBF文件（所有字段均为字符型，长度为255）。

l DBF文件转为Excel：拖入DBF文件，然后单击右键菜单，选择“另存为Excel工作薄…”，可以将DBF文件转换为Excel文件（所有单元格为文本格式）。


2.8 其它操作

Copyright ©2025 www.QuickCmp.Com 作者：李辉 版权所有.


2.8.1 在表格某列进行筛选

单击列标题旁边的漏斗图标（如下图），可对选中的此列中的值进行筛选，也可以自定义筛选条件（和Excel中的操作类似）：


2.8.2 按某列分组显示

用鼠标按住某列的标题，拖放到表格上部区域（“拖动列标题到此处可以按列分组”区域），可以按此列分组显示，如下图，把“政治面貌”这个列标题拖放到分组区域：

表格中的数据就会按“政治面貌”分组显示，并显示每组中有多少条数据，如下图所示：

您甚至可以继续拖放其它列标题，进行多层次分组显示，如下图：

上述示例中，表格中的数据先按“政治面貌”分组，再按“性别”分组显示。


2.8.3 取消分组显示

在分组区域中，用鼠标拖动希望取消分组的列标题，拖回表格中即可取消按此列标题分组，如下图：


三、常见问题

Copyright ©2025 www.QuickCmp.Com 作者：李辉 版权所有.


3.1 免费版和正式版的区别是什么？

免费版和正式版有两处不同：

l 免费版限制仅可导入和对比300条以内的数据（为了不打扰用户，软件不提示“仅导入300条数据”）

l 免费版软件的标题、主界面右上方以及“关于”界面上，都会显示“免费版”字样。正式版不会限制可导入和对比的数据条数，并且在“关于”界面上显示授权信息（注：Excel/DBF文件格式自身有最大行数限制）。

除此以外，免费版与正式版其它功能完全相同。


3.2 免费版和正式版限制使用时间或使用次数吗？

免费版和正式版均无过期时间，不限制使用的电脑数量和次数。


3.3 此软件有广告或恶意插件吗？

此软件由作者本人编写，无论免费版还是正式版，保证都不弹任何广告，无病毒、无任何捆绑，不写注册表，不联网。


3.4 我需要熟悉Excel函数或者Foxpro吗？

本软件编写的出发点就是为那些不会熟练使用Excel函数的人提供极简操作的，您不需要滨中Excel、VBA、Foxpro等等。


3.5 正式版贵吗？需要注册会员或收年费吗？

目前，正式版仅8元钱（以后若有变动，以官方网站上显示的为准），而且我会为每个付款用户手动编译生成一个专属于您的正式版，并将您的授权信息显示在软件的“关于”界面上。

本软件不需要注册会员，无会员费、年费等等的概念。一次付费，永久使用。


3.6 正式版如何购买？

请访问官方网站 http://www.QuickCmp.com查看如何购买。


3.7 使用盗版或破解版有什么影响？

盗版或破解版可能含有病毒、木马，可能会损坏您的文件。本软件正式版仅8元钱（以后若有变动，以官方网站上显示的为准），您是否愿意为了几瓶水的钱去冒险使用盗版或破解版软件？


3.8 我重装了系统，购买的软件还能用吗？

更换硬盘或重装系统不影响。


3.9 我购买后可以将软件发给其他人吗？

您不得将您购买的软件发给他人，不得发布到网上供他人下载，不得对软件进行反编译。若您未遵守，作者保留追究法律责任的权利。


3.10 我购买后不想要了，想退款，可以吗？

因软件类产品的特殊性，并且我是为每个付款用户手动编译生成一个专属于您的正式版，工作量很大，且用先付款后发送软件的方式，因此，如果付款后我已经给您发送了正式版软件后，无法退款，请先确定有购买需求之后再付款购买。


3.11 我收到了正式版软件，但上面的授权信息错了，能改吗？

由于您个人的原因（付款时备注的授权信息错误、未备注授权信息等）导致收到的正式版上的授权信息错误的，恕不修改。由于作者原因导致授权信息显示错误的，我会重新发给您信息正确的版本（不再重复收费）。


3.12 我想购买一个授权，让我的公司多名员工使用，可以吗？

请邮件联系作者：QuickCmp@163.com